E-conomic sync issues.

Incident Report for Corpay One

Resolved

E-conomic has resolved the issues.
Posted Apr 08, 2026 - 14:16 CEST

Monitoring

According to e-conomic, a fix has been implemented, and they are monitoring the results.
Posted Apr 08, 2026 - 12:49 CEST

Investigating

E-conomic is currently experiencing issues that are affecting the synchronization of entries.
You can follow updates on their status page here: https://status.e-conomic.com/
Posted Apr 08, 2026 - 11:33 CEST
This incident affected: Integrations (E-conomic).