E-conomic integration is not available

Incident Report for Corpay One

Resolved

E-conomic is reporting that this incident has been resolved.
All failed syncs to e-conomic will need to be manually synced from the invoices in Corpay One.
Posted Jul 03, 2026 - 08:31 CEST

Identified

E-conomic is currently experiencing issues, and its service is not available.
Integrations to e-conomic will be impacted and sync will fail.
You can follow their status page at https://status.e-conomic.com/.
Posted Jul 02, 2026 - 11:34 CEST
This incident affected: Integrations (E-conomic).