Nordea Payments Paused 01-06-2026

Incident Report for Corpay One

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 09:56 CEST

Update

Nordea has fixed the issues with their server, and the connection is operational again.
Please verify manually if paused payments from the 1st of June 2026 were completed in your NetBank before taking any actions.
If payments have not yet been completed, and no payment request is active in Nordea, please click Pay Now and initiate the payment again.
Posted Jun 02, 2026 - 09:55 CEST

Identified

Nordea has communicated that due to technical issues, processing of payments has been delayed since approx 11.00 CEST.
Nordea is working on solving the problem.

Some payments have missed the cut-off time for business day 01 June 2026 and will be executed tomorrow.

Please wait until tomorrow, the 2nd of June, to reinitiate paused payments in Corpay One through Nordea!
Posted Jun 01, 2026 - 13:22 CEST

Investigating

We are currently investigating the root cause of the paused payments through Nordea as of today, June 1, 2026.
This issue is only affecting Nordea payments.
Posted Jun 01, 2026 - 13:15 CEST
This incident affected: Payments (Nordea).