Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 19, 2026 - 06:00 CEST
Scheduled
We will be performing scheduled system maintenance on Sunday, July 19, 2026, from 6:00 AM to 12:00 PM (6 hours). During this maintenance window, our services will be unavailable. This work is necessary to improve the stability, performance, and reliability of our platform.
Maintenance window: Date: Sunday, July 19, 2026 Time: 6:00 AM - 12:00 PM Expected impact: Service will be unavailable during this period.
We apologize for any inconvenience this may cause and appreciate your patience as we complete these improvements. If the maintenance is completed earlier than expected, services will be restored as soon as possible.
Posted Jul 15, 2026 - 14:29 CEST
This scheduled maintenance affected: Payments (Bank Connect, Danske Bank, Nordea), Integrations (Billy, Business Central, Dinero, E-conomic, QuickBooks Online, Sage Intacct, SmartAPI, Uniconta, Xero), and Authentication and login, Send&Scan, Workflows, Email notifications.