Documents - longer processing time

Incident Report for Corpay One

Resolved

All systems are operational.
Posted Jun 08, 2026 - 08:31 CEST

Identified

We are currently experiencing significantly longer processing times for receipts and invoices than usual.

Our team is actively investigating the issue and working to restore normal processing times as quickly as possible. During this period, newly submitted documents will take longer than expected to be processed.

We apologize for the inconvenience and appreciate your patience as the team works to resolve this issue and handle the baglog.
Posted Jun 03, 2026 - 09:46 CEST
This incident affected: Send&Scan.